Home > Not Working > Gas Gauge And Speedometer Not Working

Gas Gauge And Speedometer Not Working

Contents

Quite a safety hazard when you don't know your speed you are traveling and all gages including rpm stop functioning. Does the speedometer reads 65 mph when is parked in the driveway? My husband checked the fuses and thought they were ok; but he doesn't really work on my car. Have used new switches from parts store as well as 1 from dealer. http://searchwebmedia.com/not-working/harley-speedometer-and-odometer-not-working.html

I have seen this Many Many times in Ford and Lincoln vehicles. Sounds Like A Wiring Issue. Am I going nuts are could these two things actually be related? Thanks, Kathy :disappoin vipergg07-05-2005, 06:33 PMHi ... try this

My Speedometer And Gauges Stop Working

Show more Language: English Content location: United States Restricted Mode: Off History Help Loading... The self-test still showed all the gauges moving even though they weren't working when running. I think certain E36 models, in some markets, came with oil temp gauges in this location. Location: In the Grumpy Chair Join Date: Jan 2008 Posts: 19,937 Mein Auto: E24x2,E36x2,E30x1, F150 View My Garage Replacing the cluster didn't help, therefore it's going to be something else.

Do I have to worry about my car shutting off while driving ? Reply September 10, 2014 at 4:38 pm Cindy M. i had an old jetta with this issue and my mechanic said "dont bother fixing it, it will cost more then you want to know for a car like this". Car Gauges Not Working Have it checked by a trained professional.

Thank you, Stu Reply November 23, 2014 at 4:49 am Rich have a 94 s10 blazer when you start it up the cluster lights up but when you cut the lights I also noticed my mph gauge was also not moving. Abut an hour and a half away. https://answers.yahoo.com/question/?qid=20100128225526AAZ2uf8 All the other gauges seem to be working properly.

Are the tach, temperature gauge, and any of the warning lights on the instrument cluster working? Instrument Cluster Not Working RockAuto Auto Parts 167,403 views 4:22 Fixing The Speedometer On Your Car - Duration: 2:47. Great, that's exactly what I was trying to determine - whether the whole instrument cluster was out or just the two gauges that you first mentioned.The problem could be a lack It is right under the rpm gauge.

All Gauges On Dash Not Working

Mark helpful Your Answer Add photo Photo (optional) Related Questions Speedometer not working.... 17 answers I have a 2003 Trailblazer EXT LT. look at this site Reply June 1, 2014 at 3:47 am ebonee green Honda accord 1996 4 cylinder i believe its a Dx Reply June 4, 2014 at 11:48 am Stuart Gross Have The Cluster My Speedometer And Gauges Stop Working Do you have any ideas about a speedometer not working? Fuel Gauge And Odometer Not Working Is it a ground specific to the instrument cluster?

So does it affect the a/c or not???? I drove home and parked the car. For fun and games...try banging on the dash at the time of the gauges reading inaccurate.. Weird stuff. Speedometer Gauge Not Working

Thanks, Stu Reply July 21, 2014 at 5:52 pm Ameek Hi, I have an 03 Infiniti I35 & my check engine light is on. I have a 2003 Nissan Maxima GLE (Fifth Generation), and when some of my lights in my cluster panel is working (Only one side). Thank you, Stu Reply December 5, 2014 at 1:45 pm dawn I have a 1998 honda accord ex automatic,all my gauges work except my temperature gauge it stays on hot,could it Source i read it somewhere maybe? __________________ -Franklyn Eight Thirty View Public Profile Find all threads started by Eight Thirty Find all posts by Eight Thirty View My Garage Add Eight Thirty

Check the data sticker in the driver side door jam. Speedometer And Odometer Not Working The whole instrument cluster went out then it randomly comes back on when I hit the breaks while driving. Then another mechanic told me the cluster doesn't affect the a/c.

Now the fuse 21 keeps blowing when you turn on ignition, but the truck still starts and runs there is no power windows, interior lights, radio, nothing works on the cluster.

when I connect the left side plug connector fuse won’t blow but when I connect the right side connector plug the fuse blows. I have tried to unplug and replug the instrument cluster, unplugged the fuses for the cluster by pulling them out, turn the ignition switch to the first click then shutting it Have it checked by a trained professional. Fuel Gauge Not Working I started the car and 'hit' the top of the dash and it came back alive.

river gromittoo01-15-2006, 09:44 PMit worked for me too! Zephmont 401,788 views 11:54 GM Stepper Motor Replacement and Instrument Panel Disassembly - Duration: 6:14. The rest of the cluster seems to be fine, now is it my cluster that is bad or the sending units that are bad? have a peek here It's 840.00 to replace.

ACEMAN882207-19-2005, 10:51 PMI was suprised with my 2000 that when the rear wiper motor blew a fuse the gauges all went dead the odometer stopped but it still ran just fine. When i start the truck the glow plug indicator comes on like it should and so will the transmission light will come on. Ford dealer says it's something a dealer has to replace. Today 04:35 PM by mds219 Last post by tkrotchko Today 08:37 PM 1 Replies 37 Views Attention all Super...

I'm hoping this is just a blown fuse but any help would be appreciate it. The whole car has M everywhere on its components but not sure if just look?! Oil change needed? I have been messing with lots of the new buttons and gadgets and accidentally zonked my battery.

Interestingly the trip meter and odometer were lit up - they just didn't record distance being travelled...!